Flowroute Libraries v2

Version 2 (Legacy) of the Flowroute libraries supports Messaging v2 of the Flowroute API.

Library Version Auth Scheme JSON Format Mapped API Version Services Supported
v2* Legacy HTTP Basic Auth JSON API-Compliant Messages v2
  • Inbound and outbound SMS
  • Message Detail Records (MDRs) for SMS

Python

Select Python from the sidebar, or see the source on Github.

Ruby

Select Ruby from the sidebar, or see the source on Github.

Node.js

Select Node.js from the sidebar, or see the source on Github.

PHP

Select PHP from the sidebar, or see the source on Github.

.NET

Select .NET from the sidebar, or see the source on Github. This is a convenient link to Library v1 for .NET which supports Number Management v1 and Messaging v2.

Legacy Notice

Libraries v2 are old libraries with more limited capabilities. We highly recommend that you use Libraries v3.